Retrospective Verdict Delays
Incident Report for Cisco Secure Email Threat Defense
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 15:22 UTC
Monitoring
Monitoring - As of 7 PM UTC, our Engineering team has implemented a fix to resolve the issue.

We will share another update once our Engineering teams are confident that the matter is fully resolved.
Posted Nov 13, 2023 - 22:23 UTC
Update
We are continuing to investigate this issue.
Posted Nov 13, 2023 - 19:16 UTC
Investigating
We are currently experiencing an ongoing intermittent issue with one of our processors, leading to delayed retrospective verdicts in North America. Our team is actively engaged in investigating the root cause.

We apologize for any inconvenience that may be caused by this issue.
Posted Nov 13, 2023 - 19:13 UTC