Delay in message remediation in ETD North America region
Incident Report for Cisco Secure Email Threat Defense
Resolved
This incident has been resolved and the remediation is back to normal now.
Posted Jul 25, 2023 - 14:20 UTC
Investigating
We are currently investigating a delay in remediating some of the messages in the ETD North America region. More information will be provided as it becomes available. Apologize for the inconvenience.
Posted Jul 24, 2023 - 18:29 UTC