[Email Threat Defense] Announcement: Service Degradation in North American Environment
Incident Report for Cisco Secure Email Threat Defense
Resolved
Earlier today Secure Email Threat Defense experienced a delay in email processing. This issue is now resolved and the data is up-to-date.
Posted Dec 15, 2022 - 00:04 UTC
Update
We are continuing to investigate this issue.
Posted Dec 14, 2022 - 23:27 UTC
Investigating
Secure Email Threat Defense is experiencing a delay in email processing.

We are working to address this issue and will send an announcement when it is resolved.
Posted Dec 14, 2022 - 23:26 UTC