Delay in message processing in ETD North America region.
Incident Report for Cisco Secure Email Threat Defense
Resolved
We are currently investigating a delay in the processing of messages in the ETD North America region. More information will be provided as it becomes available. Apologize for the inconvenience.

[Update]: As of 6/28 00:30, The above-mentioned issue has been resolved.
Posted Jun 27, 2023 - 16:30 UTC