Service Degradation in North American and EU Region
Incident Report for Cisco Secure Email Threat Defense
Resolved
The fix has been deployed to all environments.
Posted Jul 20, 2024 - 17:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2024 - 20:23 UTC
Investigating
Secure Email Threat Defense is experiencing a delay in email processing. We are working to address this issue and will post an update when it is resolved.
Posted Jul 19, 2024 - 19:56 UTC
This incident affected: North America (Message Processing) and Europe (Message Processing).