Service Degradation in North American Environment
Incident Report for Cisco Secure Email Threat Defense
Resolved
Secure Email Threat Defense running on North America region also recovered now.
Posted Mar 29, 2024 - 09:26 UTC
Update
Secure Email Threat Defense running on India region is fully recovered now
Posted Mar 29, 2024 - 08:56 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 29, 2024 - 08:46 UTC
Monitoring
A fix has been implemented. The delayed messages are being processing now. It will take some time to fully recover
Posted Mar 29, 2024 - 08:45 UTC
Identified
The issue root cause has been identified and our engineers are working on a solution
Posted Mar 29, 2024 - 07:34 UTC
Investigating
Secure Email Threat Defense is experiencing a delay in email processing. We are working to address this issue and will post an update when it is resolved.
Posted Mar 29, 2024 - 06:48 UTC
This incident affected: North America (Message Processing) and India (Message Processing).